1

I have a provider hosted app that requires permission to read "user profile". When I add the permission in my manifest file and deploy it I get the message "Your tenant administrator has to approve this app". Since I am a TA I request approval and also approve the app on the "/appcatalog/apprequest"(_layouts/15/addanapp.aspx) page. After that the app on my "waiting for approval"-page, it says "Approved" under the app but:

  1. When I go to site content page it still says that my app needs approval and I can chose to re-do the approval again and again

  2. When I click on "app information" on the addanapp.aspx-page I get the message "Invalid ID for a SharePoint app".

I have registered the app with _layouts/appregnew.aspx, generated client ID and client secret, and copied those values to my add-in before deploy

STEP 1 - When clicking on app as "installing user" enter image description here

STEP 2 - Approving the app as tenant administrator enter image description here

STEP 3 - Back as "installing user". enter image description here

When going back to app-->Information I still get the message from step 1 and its stuck on last version

1

There are some changes to the approval step.

After your first step, go to the App catalog > App Requests list as below:

enter image description here

Now click on the App in the app request lists. Since, you are tenant admin, you should see the below screen. Click on the Approve button here.

enter image description here

3) Now, go to your site and install and trust the app again. It should work now.

  • Thanks :D, this worked! This is literally insane (in the artificial membrane)! How can the old flow still be there if you happen to click on the edit-icon->properties and then approve, AND JUST NOT WORK without any information whatsoever, nor any error messages!!! grrr... Anyway, thanks a bunch, it has been driving me koko – Cowborg Oct 9 '17 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.