1

Above is the data, however the search criteria need to be exact.

I tried to search data and type in "AA" but it doesn't return result. It has to be exact type in "AAA"

any idea?enter image description here

0

Edit1:

Whenever you add any new column to the list, it will take some time to show the search results. But not too long, at after an hour you should able to see the columns. If this is not working you can try below idea,

  • Create these columns as site columns and add to this document library instead of list columns. Now try to search after couple of minutes.
  • If step 1 is not working, then create a managed property for this site column and try again search.

I would say that it depends on the type of column that you are using and its metadata,

Microsoft says its primarily due to full-textQueryable need to be true. That you might need to check it out.

When you construct your KQL query by using free-text expressions, Search in SharePoint matches results for the terms you chose for the query based on terms stored in the full-text index. This includes managed property values where FullTextQueriable is set to true.

For example , in my case I have many content that has "Add" in it,

It might be Adding, Addition etc.

So when I search "Add" It would display the results including Adding too. enter image description here

If you would like to display in your case you can search "AA*"

Using words in the free-text KQL query

When you use words in a free-text KQL query, Search in SharePoint returns results based on exact matches of your words with the terms stored in the full-text index. You can use just a part of a word, from the beginning of the word, by using the wildcard operator (*) to enable prefix matching. In prefix matching, Search in SharePoint matches results with terms that contain the word followed by zero or more characters.

For example, the following KQL queries return content items that contain the terms "federated" and "search":

federated search

federat* search

search fed*

KQL queries don't support suffix matching.

Please refer KQL Syntax Reference

  • 1
    Thanks John.... it works but somehow it only search the "first name" and "last name" column, it doesn't work like "address" , "telephone number". I did tried to go "site setting" but ..... there's tones of setting inside... can't figure out. .... U know how to search all the columns ? – sphenix Oct 7 '17 at 11:42
  • Edited my Answer , please let me know if that works for you! – John Zachariah Oct 7 '17 at 12:46
  • 1
    thanks john, it worked now and I realised there a button "reindex list", mean no need to wait after new entry ..... – sphenix Oct 8 '17 at 9:57
  • Please up-vote/accept it as answer if it really helps you ! Glad to help you! – John Zachariah Oct 10 '17 at 6:59
  • sorry....how to vote/accept? I dont see the button though.... – sphenix Oct 11 '17 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.