4

Some users having an issue after the system upgrade, Please takes a look the scenario

Opening Office documents from Sharepoint 2010 in Office 2016

User machine Configuration: Windows 10, Office 2016 ProPlus, Office 2010 Components (not full installation), IE11 IE 11 Manage Add-ons SharePoint OpenDocuments Class Enabled

Scenario:

  1. User click on the document in SharePoint 2010 ( Doc library settings set open documents in Client application) Open documents in the browser and click edit with word/excel error message popup “to open this document your computer must be running a supported version of Microsoft word/excel.”
  2. If user clicks on the drop-down option next to Document and choose edit in Microsft word/excel/powerpoint a. Open the document in client application b. Edit and Save, only save as option available, Not able to save directly to SharePoint 2010

Any insight into this issue? Could be multiple offices in the same machine?

1

Solution for SharePoint 2010 and 2013 and Office Pro Plus 2016

  1. In Office 2016 setup, make sure Microsoft SharePoint Foundation Support under Office Tools is installed?
  2. In IE, disable SharePoint OpenDocuments Class and then enable again.
1

First, it's highly recommended to use the office version corresponding to the SharePoint version!

Second, Based on Hardware and software requirements (SharePoint Foundation 2010) the SharePoint 2010 works best with Microsoft Office 2010, also works with Microsoft Office 2013.

Third, There is a compatibility issue with SharePoint 2010 and Office 2016 especially with Windows 10, where the Modern Authentication feature is by default enabled in Office 2016.

  • Fortunately, you can disable this feature, this is would solve the issue!
  • But unfortunately it may cause other issues like keep prompting for outlook authentication!

To disable Office 2016 Modern Authentication

  • Run > Regeidt.
  • Navigate to > HKEY_CURRENT_USER > Software > Microsoft.

enter image description here

  • Office > 16.0

enter image description here

  • Common > Identity > double click on enableADAL > set it to 0.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.