4

We have a fresh new SharePoint 2016 farm with HTTPS. We are trying to connect to this farm using different mobile devices. When we are using iPhones and Safari the website just keeps asking for credentials over and over again.

Other mobile devices seem to be fine.

I've found this on StackOverflow:

This issue occurs as the SharePoint Authentication is not compatible with the IOS

As of now this issue has been reported but the change is required from the Apple end, such that the iOS accepts the SharePoint Authentication.

Is there any official statement from Microsoft that admits this problem?

Update

My Client tried their MAC and they get a problem there as well:

enter image description here

Accessing the site from the laptop worked for them.

  • what is your IOS version? – Waqas Sarwar MVP Oct 2 '17 at 0:10
  • it's iOS 10.3.2. – Denis Molodtsov Oct 2 '17 at 0:11
  • have you tried Chrome browser on the IOS device? – Waqas Sarwar MVP Oct 2 '17 at 2:41
  • I did, I had the same problem with Chrome – Denis Molodtsov Oct 2 '17 at 20:30
  • people having issue, what we did is just use the desktop site on it ipads. have u tried mobile app for it – Waqas Sarwar MVP Oct 2 '17 at 20:52
0

I think, I've just solved it.

I've disabled HTTP/2 by creating two registry keys: under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters

EnableHttp2Tls REG_DWORD 0
EnableHttp2Cleartext REG_DWORD 0

enter image description here

After the registry change I had to restart the server. Only after that I was able to login to the site from Apple devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.