0

I created a list about a week ago (Custom List) and created a view from the DataSheet View template - and it works just fine. Today I created another list (Custom List) and then tried to create a DataSheet View and it let's me create it but it does not actually display in DataSheet View. Its some other format.

I'm perplexed because of the fact that it works on 1 list and not the other. The lists are on different Sites, although same Site Collection. But it seems it must be a Site issue and not something like Browser, 32 vs 64, etc. - I open the two lists side by side (in Chrome, or IE, or whatever), and the one displays properly and the other does not.

List with working DataSheet View List with non-working DataSheet View

0

Can you check the Quick Edit Option on List Menu from Ribbon which will bring you the DataSheet view or Quick Edit mode to the List.

enter image description here

also check this option in List Advance settings whether it has been selected .

enter image description here

hope this helps.

Note : This feature is not supported in External Lists.

  • Yes - the Quick Edit is enabled in the Advanced List Settings. And the button is enabled in the All Items view. This is not what I'm looking for, however. I want the list to default in datasheet view. It also is not an External List. I'm especially confused by why two nearly identical lists would give a different result: one allowing the datasheet view the other giving an error. – Joel Charles Oct 2 '17 at 13:38
  • have you checked by replicating the issue in another list and please make sure that there is no error in the console while the page renders , check it in developer tools of the browser . still if the site misbehaves if you have the control over IIS Reset give it a try sometime it works. – Esaki Oct 2 '17 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.