I don't know what is going on, but I see what the issue is now as to why it's not saving properly.

I created a column "Name" via the list edit functionality and went to add data via a .ajax query and its telling me that no property 'Name' exists. So I go and look at the list column name in the Settings and its now named "dvjh" internally.

So I deleted it, went to the list settings, created a new column "Name" and went back to check to make sure it was actually called "Name" now and it was, but I try again and same error.

So I go query the SharePoint API in the browser and now the column is named: "iskh".

How can I get SharePoint to stop changing my column names to something ridiculous and make them keep the name I give them internally?

1 Answer 1


"Name" isn't allowed as a field name. If you try to add a field other ways, it will generate an error. For some reason, the "edit list" feature doesn't throw the error, but it gives the field a different name. Perhaps create field with a slightly different name, and then use list settings to change the display name of the field. This way, users will see the display name, but programatically, you'll be able refer to something a bit less random.

  • 1
    Aggh! Thank you for this!! now I feel like an idiot...
    – MattE
    Commented Sep 27, 2017 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.