1

I've installed Feature Pack 2 and developed simple "HelloworldwebPart".

I created two sites in my WebApp Example :

Team Site : https://<Domain>/Sites/Test

App Catalog : https://<Domain>/Apps/Catalogs

Upload the SPFx webpart to App catalog site -- no error and issue.

Didn't see apps when I try to add the Webpart to main site (https://<Domain>/Sites/Test >> Site content >> Add an apps).

Any Suggestions please ?

  • Have you verified in the app catalog that the solution package doesn't contain any errors and has been deployed correctly? – Waldek Mastykarz - MVP Sep 28 '17 at 16:56
0

Have you done the full setup for apps in your on-premises farm? At a high level, this includes:

  • Creating the forward lookup zone and CNAME alias in DNS
  • Configuring the Subscription Settings and App Management service applications
  • Setting up app URLs in Central Administration

If so, have you also granted access to the App Catalog to the user who is attempting to add the app and can't currently see it?

  • I've completed the setup and user has permission but still unable to see the apps. – user70602 Oct 2 '17 at 21:25
  • hello @user70602, did this issue ever get resolved? we are facing similar issue on customer env although it is for traditional SharePoint provided hosted app on SP 2016 SP2. – windfly2006 May 14 '18 at 15:17
0

Here is what I have to do to see the webpart. Uses a keyword which returns noly your webpart, it will return something like below,

We didn't find a match here, but check out the SharePoint Store.

We didn't find a match here, but search across all your apps.

Click on "Search across all your apps". You will see your app.

However, I can't add it. It says "Sorry, apps are turned off. If you know who runs the server, tell them to enable apps." Do I really need to install App service? SPFx is not running on App domain, it runs on page's context.

0

SPFX webparts don't need full setup of apps! Just type in a fictional URL in the app URL's central administration section and wait a few moments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.