1

Recently I've upgraded our SP2010 farm to SP2013. When sharing sites or others objects with someone, there is a "send e-mail invitation" check-box and it works fine on SP2010 visual sites but it is not working at SP2013 visual sites. I've found a thread like this. Does really SP2013 use logged on users credentials to send e-mail? Is there any option to send invitation e-mail using farm account like SP2010 does?

Edit: It can be true. When I logged on with farm account I am able to send e-mail invitation but when I logged on with my personal account I can not. Is there any document about this?

1

To investigate this issue, You should first be aware of

  • By default, the Share option will be only available for Site Collection Administrators regardless the Outgoing Email settings is configured or not.

  • Once you have configured Outgoing Email settings, the Share option will be available for all users.

  • Only the users with Manage Permission will be able to Grant Permission, so they will be able to Share the sites without any issue like send e-mail invitation.

enter image description here

enter image description here


So in your case, to be able to send e-mail invitation, you should make sure that

  • You have configured Outgoing Email settings.

To configured the Outgoing Email settings for a web application go to

  • Central Admin > System Settings > E-Mail and Text Messages (SMS) > Configure outgoing e-mail settings.

enter image description here

  • The Personal account has at least Manage Permission to be able to Grant permission.

Otherwise, you should check with your Exchange Administrator to make sure that there is no restriction to send an email with your personal account.

  • Outgoing e-mail configurations are okay @M.Qassas. All e-mails works fine. I'm also a site collection administrator and I am not able to send invitation e-mail. When I use farm account, I am able to send. It maybe because of SP2013 architecture but I couldn't find any documents about this. – newbie Sep 26 '17 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.