3

I created an app catalog and a developer site

Then I uploaded the SpFX Webpart package enter image description here

But the Webpart is not listed in the app gallery of my developer site so I can't use the web part. enter image description here

Any tips?

  • What is file extension ? – Bhaskar Dhone Sep 23 '17 at 7:53
  • file extension is *.sppkg – Cellist Sep 23 '17 at 8:41
  • Go to “apps for sharepoint” in app catalog and change the view to “unavailable apps”. There you can see if the app deployment has any issue. – ThinkB4Code Sep 23 '17 at 10:42
  • the list of unavailable apps is empty – Cellist Sep 23 '17 at 11:00
  • Cellist.. I've same issue, can you please help. I've installed Feature Pack 2 and developed simple "HelloworldwebPart". I created two sites in my WebApp Example : Team Site : https://<Domain>/Sites/Test App Catalog : https://<Domain>/Apps/Catalogs Upload the SPFx webpart to App catalog site -- no error and issue. Didn't see apps when I try to add the Webpart to main site (https://<Domain>/Sites/Test >> Site content >> Add an apps). Any Suggestions please ? – user70602 Sep 27 '17 at 4:14
2

I found the answer in Microsoft docs: Client-side web part visibility in SharePoint sites Web parts included in solutions which have been centrally deployed, will be immediately visible in the web part picker in both classic and modern pages.

0

I figure out the solution, you need to use the following command in your console before create the solution.

gulp bundle

then create your solution again and reinstall it in app catalog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.