2

I am facing this weird behavior inside my SharePoint enterprise farm 2013. when i have enabled the "Community Site Feature" inside my team sites.

The problem details is as follow:-

  1. I have 2 site collections (SiteA & SiteB). both are of type team site. and both have the publishing features enabled at the site collection level and at the root site level.

  2. Now inside both site collections i have many team sub-sites, where i have added the built-in Discussion board list inside them.

  3. And users were adding discussions and replies inside these discussion lists without any problem.

  4. Now a new requirement has been raised by our customer that they want users to be able to mention others in the discussion items and replies.

  5. So based on my reading, i realize that i need to enable the "Community Site Feature" site feature on the sub-sites, to be able to mention users inside the discussion items and replies. now enabling this feature have created a new discussion list , but i do not want to use this new list as i already have the old discussion lists which contain many items.

  6. And i enable the "Community Site Feature" site feature on all the sub-sites.

  7. Now when i test mentioning users inside the discussion board list, i got 2 different behaviors as follow:-

    • Now on the team sub-sites inside SiteA, when i mention someone inside the discussion as follow:-

enter image description here

  • This will appear under the Mention section inside the user's mySite, as follow:-

enter image description here

  • But the problem i am facing that on the team sub-sites under the SiteB, i can mention users, but this activity will not appear on their mysite's mention section.

  • Now i tried to figure out what could be causing this, but could not find any solution.

Now today i noted that on the sub-sites under SiteA which are working well (where mentioning someone will appear on the users' mysite) that the discussion counter will be counting discussions for the 2 discussion lists which i got (the old discussion list + the new discussion list which was created automatically when i enable the "Community Site Feature"). For example, when a user add a discussion inside the old discussion list the counter will be as follow:-

enter image description here

also when a user add a discussion on the list which was created automatically (i added items inside this list for testing purposes only) the counter will be reset as follow to match the items on the new list,and so on..:-

enter image description here

but on the team sub-sites under SiteB, where mentioning someone will not be shown inside the users' mysite Mention section, the discussion counter will only be updated if users add new discussion/reply inside the new discussion list !!!

i know it is a long story, but this is the weirdest and most frustrating issue i have ever faced!! now i want to be able to mention someone inside the old discussion list and have this activity appear inside the mysites... i am not so worried about the discussion counters inconsistency which i got !!

one final note that on all the sub-sites either under SiteA or SiteB, mentioning a user inside the discussion list which was created automatically will always be shown inside the users' My-site under Mentions section. but i do not want to use this list as the old discussion list already have many items and setting applied to it..

Now i have a feeling that since the discussion counter will be updated on SiteA's subsites, so this mean the "Community Site Feature" was fully enabled/associated with the old discussion list and as a result mentioning someone will appear on the users' mysite.. but on SiteB's sub-sites seems the "Community Site Feature" was not fully enabled/associated with the old list since the counter will not be updated wehn users add discussion items inside the old list. and as a result mentioning someone will not appear on their mysites.. i am saying fully enabled/associated because when i enable the "Community Site Feature" i am able to mention users inside the new and old lists.. but on SiteB mentioning a user will not appear under the user my-site..

So can anyone advice on this problem please?

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.