1

I'm having an issues pulling lookup columns from List A and displaying them in List B.

List A has manufacturing sites with columns including the site name(Title), Site Region, Site ID, and Site Lead.

List B has its own columns along with some of the columns from List A. I create a new lookup column with the "Site (Title)" and check the Site Region, Site ID, and Site Lead columns checkbox in the List B SharePoint designer "Edit Columns" page. However, Only the Site (Title) and Site Region columns display data in List B, the other 2 (Site ID and Lead) show blank when they have values that show in List A.

List A: enter image description here


List B: enter image description here

I even tried creating a plain text version of the "Lead" address book lookup column and it's still showing up blank (and yes the sites in list B do have values for Lead and Site ID in list A). What seems to be the issue here?

  • Your scenario should work without any issue. There could be some other thing that's creating this behavior. 1) Can you see any javascript error if you open this page in chrome? Or any error in Network tab? 2) If no error, uncheck Region and Site ID in "Site" column of List B and see if "Lead plain text" comes up? 3) Create two new lists with plain text columns in ListA and a lookup column in ListB. See if same behavior appears? – Ahmad Zia Sep 18 '17 at 1:56
  • Hi Ahmad, I tried all of the following scenarios; no issues in the chrome property inspector (JS or network), I unchecked region and site ID but Lead plain text does not come up, also created 2 new test lists and used lookup columns from list B in list A and the exact same columns aren't showing up (Lead plain text, and Site ID). At this point I'm still confused. As far as the contents of the columns go a sample site id would be: FR-123. A sample Lead would be: Smith, John. – Claude Sep 18 '17 at 18:44
  • your issue seems machine specific, can you check the ULS logs on the server when you refresh the list view page? This might indicate some error. Also try removing the JSLink. – Ahmad Zia Sep 18 '17 at 23:46
  • I don't seem to have access to the ULS logs, checked (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\ and \16) but they're not in there. Also I removed the JSLink and still same issue... – Claude Oct 4 '17 at 13:26
  • Please try three things. 1) Check on different web browsers like Chrome or Firefox and see if the results are same. 2) Can you apply seattle master page just to make sure its not a master page issue? 3) Right click on the blank text in normal view mode and inspect to see what html is there? The Site:Site ID or Site:Lead plain text might be there but invisible due to some css. – Ahmad Zia Oct 4 '17 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.