We are using Sharepoint Designer 2007,In which we try to open any page in designer we get following error, "The Server could not complete your request. Contact your Internet Service Prvider or Web server administrator to make sure that the server has the FrontPage Server Extensions or Sharepoint Services installed" When I click on Details button then I found next message "soap:ServerServer was unable to process request. ---> Cannot complete this action. Please try again. ---> Cannot complete this action. Please try again."

Kindly help me on this issue as we are not able to code anything.

Thanks in advance, Rushikesh

  • Are you trying to open it from the server or from a workstation? Nov 2, 2011 at 12:32
  • We are opening pages from sharepoint designer 2007 and designer is installed on local machine
    – Rushikesh
    Nov 2, 2011 at 13:20
  • sorry about the non-answer comment from earlier... What authentication model are you using on the site? NTLM, Kerberos, FBA? Nov 2, 2011 at 13:21
  • Hi David, We are using Windows authentication. Thanks for your prompt reply.
    – Rushikesh
    Nov 2, 2011 at 13:45

5 Answers 5


Check Central Administration > Application Management > Authentication Providers > Edit Authentication -> "Enable Client Integration ?" radio buttons. It should be Yes.


First thing to validate is that you're using an account that has SharePoint Designer access, which I'm assuming you are. Typically you see an access denied error if that's not the case.

Are you seeing the same behavior from multiple machines and multiple users, or is it a specific machine/user?

SharePoint Designer uses SOAP requests to handle the vast majority of functions; I would be curious to see if your farm's web services are functioning correctly. This error sounds like something physically wrong with the farm, where possibly one or more of the services SPD is trying to connect to are either blocked due to network configuration, or not running.

Step 1, try another user and another machine to identify if it's a permissions or local configuration issues.

Step 2, check the ULS logs on the servers to see if SharePoint is getting the request and throwing an error.

  • Hi, Thanks for your response, yes we are accessing from multiple machines and users.
    – Rushikesh
    Nov 2, 2011 at 13:27
  • Is each user/machine getting the same error or just one? Nov 2, 2011 at 14:05
  • I'm a little lost as to what you have/haven't tried at this point. Is every user getting the error, or just one? Have you checked your ULS logs?
    – webdes03
    Nov 3, 2011 at 13:30
  • Hi, Yes All users are getting same error. We have not checked ULS Logs,from where I can check it? We checked following things, 1) If any webpart is remaining closed then we deleted them. 2) Recycle Applicaion pool 3) Reset IIS 4) Restart server. Thanks, Rushikesh
    – Rushikesh
    Nov 7, 2011 at 6:06
  • By default, your ULS logs will be located in c:\program files\common files\microsoft shared\web server extensions\12\bin. The ULS logs should indicate any issues from a farm/configuration standpoint, ie: trying to communicate to a service that isn't running, failed requests, broken components, etc.
    – webdes03
    Nov 7, 2011 at 14:41

I see this every now and again, typically restarting the IIS services resolves the issue for us.

  • Hi PirateEric, Thank you for your reponse,we have already tried restarting IIS but no luck :(
    – Rushikesh
    Nov 2, 2011 at 13:50

In my case I had to find what a webpart is the cause of the problem and to remove it from the page.


I know it's late to answer this question, but maybe this helps someone. A possible cause might be a low memory issue.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.