5

I created a new custom list , I added columns (17 columns), I went back to The all items page , it show this error

TypeError: unable to get property 0 of undefined or null reference

PS- The list is empty

  • 1
    Maybe have to install a cumulative update. – devnation Sep 10 '17 at 7:57
  • Were any of the columns lookup type? – Taterhead Sep 10 '17 at 12:33
2

Try to trace your issue by doing the following:

  • Create a new view from existing view that has the issue.

enter image description here

  • In your case start from all items view.

enter image description here

  • Start removing the columns one by one from the latest added to the oldest.
  • Every time you remove a column, try to check if your view is rendered properly or not.
  • In case the view is rendered properly so the last column you have removed is the column that causes the issue.

  • Now try to check if you face the same issue with a new list or not? if it's a general issue for all lists so try to find the latest CU installed in your farm and install a new CU.

    • It's recommended to install the latest CU - 1)
    • Note all new CU requires SharePoint 2013 SP1 installed.
  • If the issue still not solved after applying the new CU, So try to contact Microsoft.

  • Your guidelines helped me , remove task outcome column solve the issue , I want to know why the task outcome cause fault render – Sharan Piris Sep 11 '17 at 15:23
  • what's your current CU installed in your farm/ – Mohamed El-Qassas MVP Sep 11 '17 at 15:32
  • Service pack 1!! – Sharan Piris Sep 11 '17 at 15:41
  • 1
    I have SP 2016 and I can add this type of column, Do you able to install a new CU? if yes go ahead to install the latest CU (current month -1) otherwise use the choice field instead – Mohamed El-Qassas MVP Sep 11 '17 at 15:44
0

Try this solution :

Go to Modify view in ribbon then Change field "Item Text (linked to item with edit menu)" to "Item Text (linked to item)".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.