0

I am facing a issue while trying to access the sites.asmx service via url for the same sharepoint version.

I have two different web applications running SP 2007 and when I m entering the "http://server1/_vti_bin_/sites.asmx" I get the below methods.

ExportWeb GetSiteTemplates GetUpdatedFormDigest ImportWeb

and when I am accessing the "http://server2/_vti_bin/sites.asmx" I get the below methods

CreateWeb DeleteWeb ExportSolution ExportWeb ExportWorkflowTemplate GetSite GetSiteTemplates GetUpdatedFormDigest GetUpdatedFormDigestInformation ImportWeb

Clearly the web methods in both the cases are not same. So I want to know how to get the missing methods in server1. Do I need to make any changes in server1 to get all methods.

FYI, My Sharepoint CSOM code internally calls this web service and I have not referenced it explicitly. When the code calls server2 my code works fine but when it calls server1 it fails.

Regards, Agasthya

0

As the server1 is running SharePoint 2007 so CreateWeb method is not available. It is available in SharePoint 2010 and 2013.

Have a look at the msdn documentations below

SharePoint 2007: https://msdn.microsoft.com/en-us/library/sites.sites_members(v=office.12).aspx#Public Methods

enter image description here

SharePoint 2010: https://msdn.microsoft.com/en-us/library/websvcsites.sites_members(v=office.14).aspx#Methods

enter image description here

  • Hi Ahmad, Both my web applications are SP 2007. I was unable to figure this out due to which I had opted a workaround by using other services to complete my requirement. – agasthya Nov 17 '17 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.