0

I have created a list using "Custom List in Data Sheet View". After that I created around 10 columns in that list. Problem is only for one column, it is showing as read only, rest all are working fine!! Hence I cannot insert a row in the list(Data sheet view).

How can I remove that read only attribute from the column?

One more related question is, how to make the list editable to only one group and read only to other groups?

Thank you, for your valuable inputs!!

3

You should go to list tab on the ribbon, then open list permissions settings. In this settings you can add two groups (or use existed groups) and set Read rights for one group and Contribute rights for another. By default the list inherits permission from a site. You can broke this relationship by Stop inheriting permission button.

what type of this field?

  • Thank you Alex for your help, the permission link just worked great!! other regarding the column (Type is plain text)it shows read only, also the attachment column also shows read only !! Some help please !! – Jithu Nov 2 '11 at 7:00
  • I have not got any ideas :( – Alexander Nov 2 '11 at 7:59
  • 1
    That's fine I just re edited, one of the column, and the read only option has just gone.. Though the attachment column has it even now!! Thanks! – Jithu Nov 2 '11 at 8:07
2

I had a very similar issue. I'd added a Rich Text column for notes to an existing list. I could add text to the Notes field if I opened each list item and edited individually but edits to that field when in Datasheet View were met with "the selected cells are Read-Only".

I simply altered the rich text format to be plain text and it cleared up the issue.

1

I had a similar issue. I added a new column to a SharePoint list. The column type is "Multiple lines of text." The text type was "Enhanced rich text." I was unable to paste data into the column in datasheet view. I received an error message indicating that it is read-only. To solve my problem, I changed the text type to "Rich text."

-2

Go into File. Click on Publish. When you get to the option to select the columns, click on the desired column and then click modify. Select the option to allow users to edit data. Repeat for all desired columns and complete publishing process.

enter image description here

  • 1
    Go into what file, from what program? – Erin L Aug 19 '16 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.