0

I am trying to update a Shared Secret for an on Premise Farm. I have a 2013 Workflow Server that stopped working after a year. This is the error that I am receiving when I run a 2013 Workflow:

Invalid JWT token. Could not resolve issuer token

I found this article on Updating the Secret but it appears to be only for SharePoint Online. https://dev.office.com/sharepoint/docs/sp-add-ins/replace-an-expiring-client-secret-in-a-sharepoint-add-in.

I am stuck on signing in with the Power Shell command "Connect-MsolService". The instructions imply that this is the method works for On Premise but the form doesn't like the Administrators credentials.

Can someone help me with this method or direct me to a better tutorial for On Premise Farms?

Log in form; opened by running this command in Power Shell: Connect-MsolService

1

I solved my underlying problem, however, I did not follow the steps in the article above. The issue was because something was out of sync. I solved the problem by running all the Timer Jobs on the Farm.

Here are the sequence of events:

  1. 2013 Workflow stopped working after a year.
  2. Uninstall Workflow Manager and associated programs.
  3. Delete Workflow and Service Bus databases.
  4. Install Workflow Manager.
  5. I got the problem in this Question.
  6. Ran all the Timer Jobs on the Farm; with script below.
  7. 2013 Workflows work again; only true for Workflows created after step 4, old Workflows are lost.

PowerShell to run all Timer Jobs:

Get-SPTimerJob |% {
    echo $_.name
    Start-SPTimerJob -Identity $_

}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.