0

I followed this article and created one reusable workflow and set it to run manually

I gave Read permission to the users at the site level and contribute permission at the library level alone by breaking inheritance and changing permissions where the workflows are associated

Now the issue is that unless I give contribute (in particular Edit items permission) permissions for the users at the site level, users are not able to see the list of workflows available to start manually.

However, workflows that are set to run automatically when item is created or changed are running fine without any issues though users are not able to see the workflows

Can someone help me with this issue, please?

2
  • Please check this Elevate Workflow Permissions in SharePoint Sep 6 '17 at 12:23
  • No, i am just updating column values of the library and sending emails using the workflow, so i didn't use any app step, so i didn't use any app permission as well and the problem is workflows are not visible at all, it is not about starting the workflow
    – Yaswanth
    Sep 6 '17 at 12:52
2

Contribute permission is required.

4
  • Can you please add more details about how to implement this solution? Sep 6 '17 at 14:23
  • i guess you are telling contribute permissions are required at list/library alone, which i did, i guess this contribute permissions not required at site level, but users who have contribute permissions at site also are only able to start the workflow manually
    – Yaswanth
    Sep 6 '17 at 16:29
  • You need contribute permission at site level because user if you give permission to list only that u need to give permission for workflow task list also. So, it's better if u give contribute permission at site level.
    – Akshay
    Sep 6 '17 at 17:07
  • I have given contribute permissions to both workflow history and tasks list by breaking inheritance, still workflows are not visible to users, workflows are visible only after i gave contribute access at site level.., i have seen someone mentioning similar issue here
    – Yaswanth
    Sep 7 '17 at 6:15
0

Did you check manually start workflow? If you did not, you can not see workflow at browser.

enter image description here

1
  • yes, i have selected the option, as i said in my post, users who have contribute access at the site level are able to start the workflow manually, but ideally contribute permissions are required only to the list where workflow is associated, not at site level
    – Yaswanth
    Sep 6 '17 at 16:27
0

A workflow kicks off when an Item is created in a library/list. So a user will require at least contribute permissions to create items in a list and workflow will be initiated. When you configure a workflow make sure you check these two boxes:

  • Allow this workflow to be manually started
  • Start Workflow automatically when an item is created
  • Start workflow automatically when an item is changed (optional)
1
  • yes, i have selected the option to start workflow manually, as i said in my post, users who have contribute access at the site level are able to start the workflow manually, but ideally contribute permissions are required only to the list where workflow is associated, not at site level
    – Yaswanth
    Sep 6 '17 at 16:27
0

I could be late in answering this but doing this for any one who might come to search for this later on.

You need to enable "Workflows can use app permissions" site feature for you to be able to give your workflow permissions of editing lists and libraries.

Go to site setting, under site actions click Manage site features, look for "Workflows can use app permissions" and activate it. Your workflows should then work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.