1

I have a domain user which has disable the button 'Open with Explorer' in a Library. So far, I tried:

  1. Windows 10 with IE11 32 bits (runned from C:\Program Files (x86)\Internet Explorer\iexplore.exe)
  2. The user has Full Control in the Library and also in the Site
  3. The site is included to the 'Trusted sites' on IE.
  4. Other user in the same PC can 'Open with Explorer' the Library
  5. The problematic user has the same problem in others workstations.
  6. I tried the user as local administrator.
  7. The user can connect to the Library as a 'Mapped drive' on Windows Explorer.
  8. Copied the user in the AD, creating a new user which belong to the same groups as the former user, and this new 'clone' can 'Open with Explorer' the library, but the original user yet has problem
  9. Webclient service is running

note: it's a Sharepoint 2013 Foundation with Windows 2008 R2, clients are Windows 10 with IE11. Ohers user in the AD, even in the same OU, have enable the button.

Some clue, please?

0

this is not so much a solution but more of a workaround that you can potentially use to further troubleshoot the issue

  1. fire up IE and open e.g. http://contoso
  2. open dev console (right-click > inspect element)
  3. in console, paste (after placing your own domain in the url)

    CoreInvoke('NavigateHttpFolder', 'http://contoso', '_blank');

this should be similar to clicking the file explorer button. perhaps if it fails, it can provide you additional information, either in the console, or in a dialog box

usually when I see a greyed out explorer button, I think it's one of these, but from your tests, it's looking like some AD profile issue

  • wrong browser (chrome, edge)
  • desktop experience not installed (server) and/or webclient service
  • Thanks @Tiago. I'm a bit lost in the 3rd step: I open de 'Developer Tools' (inspect element open the DOM explorer) and I jump to the 'Console' tab. There I entered your code as: "CoreInvoke('NavigateHttpFolder', 'intranet.mydomain.com/site/library/Forms/AllItems.aspx, '_blank');", also without /Forms/AllItems.aspx and finally just with intranet.domain, but always get "Expected ')' " – HEDMON Sep 4 '17 at 11:44
  • in the comment before is included the 'http://' in the URL but SO won't show it – HEDMON Sep 4 '17 at 11:46
  • make sure you open your sharepoint site before inspecting and pasting the code in the console – Tiago Duarte Sep 4 '17 at 11:47
  • yep, i have open the library in IE – HEDMON Sep 4 '17 at 11:52
  • never seem a scenario where the api actually works, but the option is greyed out. perhaps you can cross match the working ad account and the non working and check where they are different – Tiago Duarte Sep 4 '17 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.