1

Using the MS github SharePoint Framework samples- I am seeing lots of typescript errors when running gulp serve

[18:04:39] [typescript] **Using custom version: 2.0.10** <br>
[18:04:39] Finished subtask 'copyStaticAssets' after 1.23 s<br>
[18:04:39] Finished subtask 'tslint' after 1.26 s<br>
[18:04:43] Error - typescript - 
node_modules\@types\angular\index.d.ts(1036,40): error TS1005: ']' expected.
<br>
[18:04:43] Error - typescript - 
node_modules\@types\angular\index.d.ts(1036,41): error TS1005: ')' expected.
<br>
[18:04:43] Error - typescript - 
node_modules\@types\angular\index.d.ts(1036,42): error TS1131: Property or 
signature expected.<br>
    .......
    .......
[18:04:44] Project angular-multipage version: 1.0.0<br>
[18:04:44] Build tools version: 0.11.1<br>
[18:04:44] Node version: v6.11.1<br>
[18:04:44] Total duration: 9.49 s<br>
[18:04:44] Task errors: 96<br>
[18:04:44] Error - 'undefined' errored after<br>
"orchestration aborted"<br>

Some of the samples from their github work and it will show "using custom version 2.2 or higher" - but if it's a lower version, like 2.0.10 above, in the build toolchain it will error out with various typescript errors.

I've tried adjusting the lodash version mentioned here: Typescript errors in SharePoint Framework webparts

Also tried switching to node version 4.6 and it didn't work. I have node 6.11.1 now. Any ideas?

0

The problem here is type script version your using is lower then node version.. So You can updated typescript to latest version and also upgraded node to latest...

You can upgrade your node using this link

Download latest typescript using this link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.