2

I have two lists. First list contains a lookup to another list, which has over 5000 items. When i try to create item in the first list, i see following error

enter image description here

Remove the column? Seriously Microsoft? I understand i can edit views to filter out items so that i over come treshold limit problem, but what am i supposed to do with this since we are talking about OOTB sharepoint new form? My collegue suggest me that i remove the Lookup column and save the reference into text field, but i really hate this idea, what is SharePoint good for then.

Is there any ootb sharepoint way to solve this issue? i must also mention that i will need to be able to use QuickEdit in this list, as users want to update multiple items quickly. When using QuickEdit, this appears in the lookup column cell

enter image description here

We are talking about SharePoint Online

1

If dividing the list into multiple lists is not an option, the jQuery autocomplete can be implemented.

  1. Create a new single line of text field.
  2. On the New/Edit form add a content editor web part
  3. Use javascript object model to query the source list "Contact Information" and fillup the returning values in an array.
  4. Assign that array to the jQuery autocomplete api.

For complete code, please refer to this link. Modify the js and css file paths in script and link tags accordingly.

Hope that helps.

1
  • 1
    Thats exactly what i am currently working on! Altough i i dont like it, it seems to be the best solution right now. The link does not seem to work, but never mind i know what to do. The only problem i am thinking of now, is what to store in the column itself, i want to store the sharepoint item id, but at the same time users want to use QuickEdit mode, so it seems i will have to only save the string value of "show column - e.g. title". I can run into issue like duplicities and so on. Anyway thanks for your suggestions, i will mark your answer as accepted if noone comes up with anything better
    – Martin
    Sep 4 '17 at 8:55
0

You should add the lookup column as an indexed column. By default ID column is indexed thats why filtering with ID column still works even though list threshold hits for your list. Please find the steps:

  • Goto list settings
  • Goto Indexed columns link
  • Add your column as indexed

May be you need to delete the list items and make list items count less than 5000 to add an indexed column.

1
  • Unfortunately that did not work
    – Martin
    Sep 1 '17 at 14:50
0

As it is SharePoint online, one solution (though not ideal) could be to divide the lookup list into 2 or more lists. The division could be yearly or monthly depending on the list items and how frequent they arrive in the list. Example divide the Contact Information list into these 3 lists.

Contact Information 2015
Contact Information 2016
Contact Information 2017

On target list New/Edit form, make 3 lookups pointing to these lists. This should work in Quick Edit as well.

1
  • I also thought about it, but since the projects list has a lookup column to contact information list, i would need a separate lookup column for each list, which just does not seem right to me
    – Martin
    Sep 4 '17 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.