3

One of the web applications in our SharePoint 2013 farm is recently unable to connect to appstore. The last thing we did is patching SP 2013 to the latest CU.

Error Message

Sorry, we can't seem to connect to SharePoint store. Try again in a bit.

Error in the log:

Request to office.com with the following ... caused a URL exception. Maybe marketplace settings are not setup. Exception details: System.UriFormatException: Invalid URI: The format of the URI could not be determined.    
 at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)    
 at System.Net.WebRequest.Create(String requestUriString)    
 at Microsoft.SharePoint.Marketplace.OfficeProxy.OfficeProxy.SendWebRequest(String url, Boolean autoRedirect, String userIP, String postBody, String contentType, Encoding encoding, String jobRunIdLogPrefix)

Response from office.com was null or its HTTP status code was not 'OK'. Actual status code: 'InternalServerError'

I have checked this post Sorry , We Can't Connect to the sharepoint store and one thing that i dont enable is Make Sure the internet access to the Store feature ACTIVATED. This feature is not enable in others web application however still able to connect to app store

  • it is now resolve. Not sure what is the cause. – Supermode Aug 28 '17 at 5:54
1

Use below command to enable the store.

Set-SPAppStoreConfiguration -Url http://office.microsoft.com -Enable $true

Make sure you have internet access from frontend Server because while adding apps from Store FE will try to connect internet.

Reference: https://technet.microsoft.com/en-us/library/fp161236.aspx?f=255&MSPPError=-2147217396

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.