2

am trying to get the web application created in one farm and port it into another farm having the same db sp 2013 versions.

I am having 3 sites

  1. 1) publishing portal site collection
  2. 2) search center site collec.
  3. 3) one archived site collection of (1) -a replica of first site collec

I took the sql content db backup from my sql srvr machine and "mywebapp_contentdb.bak" and took it onto my target farm machine.

  • I restored the content db using SSMS tool and its restored successfully.
  • I created a new web appln in my target farm and and gave the name of the content db - that's restored in my sql srvr machine- in the text box provided for my web appln.
  • I created the web appln successfully and it has 3 sites as in the source sp farm.

  • the issue is , when I navigate to the site collection page, it shows me error
  • page can not be displayed

  • restored-content-db

    • Try to reenable the publishing features using powershell. Looks like the pages library might be lost? Does the other site collections work? – Christoffer Aug 24 '17 at 8:34
    • ok,,, lemme try and revert here... – userAZLogicApps Aug 24 '17 at 8:36
    • I tried with the stsadm command and ran the activatefeature , stsadm -o activatefeature -name PublishingResources -url "vgsrvr-01:28516" stsadm -o activatefeature -filename publishing\feature.xml -url "vgsrvr-01:28516" -force but it didn't work , again am getting the same issue : page cant be displayed : – userAZLogicApps Aug 24 '17 at 9:17
    • Do the other site collections work? Are you able to navigate to site contents by adding /_layouts/15/viewlsts.aspx to your site url instead of /pages/home.aspx or sitepages/home.aspx? – Christoffer Aug 24 '17 at 9:30
    • 1
      Just reread your description and i dont think creating a new webapplication and naming the database the same will work. Try to run the powershell cmdlt mount-spcontentdatabase with correct parameter to see if it makes any difference – Christoffer Aug 24 '17 at 10:17

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Browse other questions tagged or ask your own question.