3

I am trying to install SP2013 CU Patch. The installation went successfully. However, one of the server (which is happen to be the one hosted Central Admin) reported that one of file is missing/required as show below: enter image description here

In FarmServers.aspx page it shows that this server status Installation required although only one file missing/required.

What i have tried:

  • Clear configuration cache
  • Restart the timer job
  • Reboot the machine
  • Run Get-SPProduct -Local
  • Run Install-SPService

The error above is preventing me to run the configuration wizard even via Powershell or wizard.

the error showing show in the logs

 An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: An error has occurred while validating the configuration settings.  An exception of type System.ArgumentNullException was thrown.  Additional exception information: The resourceId argument cannot be null or zero length.
Parameter name: resourceId
Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException ---> System.ArgumentNullException: The resourceId argument cannot be null or zero length

Updated on :21/08/2017

Re run the installation using PACKAGE.BYPASS.DETECTION.CHECK=1 parameters. Reboot the machine. The missing/required is still exist

Run the following command to ignore checking

PSCONFIG.EXE -cmd upgrade -inplace b2b -force -cmd -installcheck -noinstallcheck -cmd applicationcontent -install -cmd installfeatures -cmd secureresources -cmd services -install

The wizard completed successfully. however Missing/Required is still exist and the manage server page it still saying Installation required.

Also try to clear configuration cache, reboot machine, and run SPProduct-Local but the result is still the same

Thanks

  • Did you ran the configuration wizard after patching machine? – ThinkB4Code Aug 17 '17 at 5:17
  • No i can't run the config wizard since it said the file is missing as i mentioned above. – Supermode Aug 17 '17 at 5:20
  • Can you check SP logs/Event Viewer to get more specific details. – ThinkB4Code Aug 17 '17 at 5:28
  • added a error logs – Supermode Aug 17 '17 at 5:40
  • 1
    I ended force the installation using PACKAGE.BYPASS.DETECTION.CHECK=1 parameter. Hopefully it resolve the issue with missing file – Supermode Aug 17 '17 at 6:46
0

Where you ever able to install the patch on the affected server without the PACKAGE.BYPASS.DETECTION.CHECK=1 parameter? If not: You might have a SharePoint LanguagePack installed, Applied ServicePack1 on the farm in the past but did not install the LanguagePack ServicePack1.

  • no i am unable to to install without PACKAGE.BYPASS.DETECTION.CHECK=1 parameter – Supermode Aug 20 '17 at 23:43
  • i have check that resource exist in the folder C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\Resources. Then i check registry in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\15\WSS\InstalledLanguages\ and it said 15.0.4569.1506 (which is correct) – Supermode Aug 21 '17 at 2:30
0

I have tried the following solution:

  1. Download and run ROIScan.vbs in trouble server. which then give you list of issue. The script can be download from: https://gallery.technet.microsoft.com/office/68b80aba-130d-4ad4-aa45-832b1ee49602

Navigate to path and run ROIScan.vbs as below cscript ROIScan.vbs

  1. Copy Installer from working server. The location something like C:\windows\Installer to bad server something like D:\Installer

  2. Download Oputil.vbs script from http://sharepointengineers.blogspot.com.au/2015/12/installing-cumulativehot-fix-update.html

or
https://kurteichler.wordpress.com/2013/09/11/restore-sharepoint-2010-installer-directory-cache-files/

Save Oputil.vbs in D:\Installer

  1. Run the Oputil.vbs like below:

cscript oputil.vbs /RepairCache /srestorelocation=d:\installer

You should received a log when it ready saying :

Missing patch metadata. Failed to read value from: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\UserData\....\LocalPackage


Repair: .. Fixing patch registration.

Then run GPSPProduct -Local and reboot the machine however this not resolve my issue.

Then open registry using regedit and navigate to the path above. Then i compare the registry in working and bad server. In bad server i found that one missing value called LocalPackage. You can export registry from good server to bad server. However i just create a value called as String value and copy the value from good server to bad server. On value data field it said the path of installer file. On the bad server then i navigate C:\Windows\Installer\4575f10.msp and found out it was missing in my bad server installer file. Therefore, i copy the file from good server to bad server.

Then install 4575f10.msp (Microsoft 2013 Foundation core server). Once installed completed run PSCONFIG then issue is now resolve.

Hope it help someone if having the same issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.