2

While copying/moving files from site to sub-site using Explorer view, we are seeing below message from SharePoint. Pls. let us know if anyone in SharePoint community has faced this issue.

enter image description here

| improve this question | | | | |
  • Copying files through file explorer is really not reliable. This might be to do with the session get timed out. If you want to copy files/folders I would recommend that you use modern library experience it is really fast and must accurate. – SharePointer Aug 14 '17 at 18:43
  • @SharePointer, What do you mean by Modern library experience? – vikbehal Aug 14 '17 at 19:18
  • Have look at this: blogs.office.com/en-us/2016/06/07/…. But I realised that you are on 2013? Another option could you use OneDrive Sync client – SharePointer Aug 14 '17 at 19:40
  • I'm on SharePoint 2013. I'll explore OneDrive option. Any reason while copy paste from explorer doesn't work? – vikbehal Aug 14 '17 at 20:07
  • From my experience it works but very slow and unreliable because of credential and other issues. You can also try to map library as a network drive which might be slightly better. – SharePointer Aug 14 '17 at 20:10
1

I'm pretty aure it's a file/folder length issue with the target folder. Check if the new subsite folder combination is longer than the old one.

Try to copy the files/folder to the root of one of your disk drives to see that the files are OK.

| improve this answer | | | | |
  • Do you mean the URL length? – vikbehal Aug 14 '17 at 19:14
0

I guess you are trying to cop/paste directly from one SP library explorer to other. You need to paste the file into you local system first than only you can copy to new library.


though you can use below powershell referenced from another Question OR Drag and Drop option here

I would prefer to go with Powershell

    // Get your source and destination libraries
SPList source = web.GetList(web.ServerRelativeUrl + @"/SourceDocLib");
SPList destination = web.GetList(web.ServerRelativeUrl + @"/DestinationDocLib");

// Get the collection of items to move, use source.GetItems(SPQuery) if you want a subset
SPListItemCollection items = items = source.Items;

// Get the root folder of the destination we'll use this to add the files
SPFolder folder = web.GetFolder(destination.RootFolder.Url);

// Now to move the files and the metadata
foreach (SPListItem item in items)
{   
    //Get the file associated with the item     
    SPFile file = item.File;
    // Create a new file in the destination library with the same properties
    SPFile newFile = folder.Files.Add(folder.Url + "/" +file.Name, file.OpenBinary(),file.Properties,true);
    // Optionally copy across the created/modified metadata                        
    SPListItem newItem = newFile.Item;
    newItem["Editor"] = item["Editor"];
    newItem["Modified"] = item["Modified"];
    newItem["Author"] = item["Author"];
    newItem["Created"] = item["Created"];

    // UpdateOverwriteVersion() will preserve the metadata added above. 
    newItem.UpdateOverwriteVersion();                              
}
| improve this answer | | | | |
  • This is what we did. Is it a Microsoft recommendation or issue with tool? – vikbehal Aug 14 '17 at 19:06
  • sot sure, but this the limitation of windows. you can user power shell or drag and drop option(see edited answer) for move files. – cjs Aug 14 '17 at 19:14
  • I do not see edited answer. – vikbehal Aug 14 '17 at 19:18
  • please check now – cjs Aug 14 '17 at 19:19
  • 1
    thanks. actually your copy /paste is not working because you trying to copy/paste from two online location or you can say from remote locations. The file are not getting stored into you local HDD, it is in volatile memory (RAM). The buses(data lines) in your system are directed to make the data flow directly from the external HDD to the PD, bypassing the computer's memory – cjs Aug 14 '17 at 19:40
0

I found the cause. The maximum allowed size is configured in windows registry.
Apparently it's a policy put in place as a security measure to ensure a misbehaving WebDav endpoint doesn't DOS/flood the client machine.

To change this setting on the client you need to edit the registry key at HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services -> WebClient -> Parameters called FileSizeLimitInBytes. You can set this to any legal 32-bit value you wish. You may want to click on the Decimal type to make it easier to enter a value. The max value you can use in this key (4294967295) will allow you to transfer about a ~4GB file.

Once you have saved this key, you'll need to restart the WebClient windows service (or reboot your machine if you wish).
Default is 50MB:
enter image description here

I referred this blog.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.