I've recently come across a strange problem in SharePoint Designer 2013 where I create a SharePoint 2013 Workflow, associate it with a custom contenttype and start editing the workflow.

If I save and publish the workflow (not associating it to a list yet), restart SharePoint Designer, I see my Workflow not linked to my custom Contenttype anymore.

Any ideas why?

SP reusable workflow contenttype association

2 Answers 2


You should be aware of the SharePoint 2013 workflow platform doesn't support associated workflow with a content type.

If you tried to create a new Reusable workflow using SharePoint Designer, you will note that the Content Type drop down list is grayed out as shown below.

enter image description here

The only available workaround is to use SharePoint 2010 workflow platform

enter image description here


M.Qassas has already highlighted the limitation in his answer. But there is a workaround to it.

  1. Click on the file tab in SharePoint Designer
  2. Select Reusable Workflow (towards the bottom) from the given options
  3. On the right side of the page, you'll have the option to associate the content type to your workflow enabled.

Refer below screenshot for reference.

Reusable Workflow

  • Hi @Amit, that's indeed the way I set it up initially. But as I stated above: after I've set the contenttype, at some point during development of the workflow, it loses the association. In the overview page I see "Contenttype: All" and every field I previously used in the workflow is blanked out (e.g. replaced by the generic blue 'field' reference).
    – Nilsvb
    Aug 16, 2017 at 6:06
  • Hi @Nilsvb, Are you trying to move the workflow from one environment to another?
    – Amit
    Aug 16, 2017 at 7:46
  • Hi @Amit: no, just creating a simple SP 2013 workflow.
    – Nilsvb
    Aug 17, 2017 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.