3

I have a document library that has PDFs stored. I have the system to open in the client application. When I open the document, it opens in the PDF file. However, some users try to open it, it opens up in the browser.

I need for everyone to open these docs up in the application to be able to electronically sign the document. What am I missing?

  • And those users have the client installed and matched the application extension PDF to that client? – Kasper Bo Larsen Aug 4 '17 at 20:44
  • Are they all using the same browser? Different browsers have different setups on what opens what and how by default. – Graham Aug 4 '17 at 20:53
4

Try to make sure the following:

  • In your document library setting > Advanced setting, make sure that the Opening Documents in the Browser is set to Open in the client application.

  • Make sure that each user has Adobe PDF client application installed.

  • Make sure the web application Browser File Handling setting is set to Strict not Permissive in central administration > manage web application.

  • The last thing, remove the PDF extension from the allowed MIME type list by running the following:

    $webApp = Get-SPWebApplication("http://webappurl")
    $WebApp.AllowedInlineDownloadedMimeTypes.Remove("application/pdf")
    $webApp.Update()
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.