2

I would like to change the width of the fields in the EditForm (Sharepoint 2013). The column named « Détail du log » is text column with « add modifications » enabled . The goal is to display all the entries . enter image description here

So, I followed this example : Change size of newform.aspx when clicking new item It is said to :

  • First create a new custom form. Go to the list where you want the new form and edit the form in SharePoint Designer.
  • Then create a new form (1), give it a name (2), select which kind of form (3), option to set it als default (4) and click ok (5).
  • Then open the newly created form in advanced mode (right click on the new form):
  • In my environment it is line 24 where you can edit / change the width of the form.

After doing this, the width of the form has been changed (great !) but I lost the display of the versions for my « Détail du log » Column : enter image description here

Do you know what can I do in order to have large fields AND to keep the versions ? Thank you very much for your help.


enter image description here

Maybe, I can go to List => Modify webpart component => choose "modify the default form" and then add a script editor ???

3

No need to create a custom edit form, just do the following:

  • Open your edit form in IE, Click on F12 (to open developer tools).
  • In Dom Explorer, Click on 'Select element' arrow to select your multi line field, you will note that it's a text are tag with class name "ms-long"
  • Now edit your page, from site setting icon > Edit page.
  • Add a script editor.
  • Add the below style based on your width

    <style>
     .ms-long
       {
         Width: 500px !important;
       }
    </style>
    

Output

enter image description here

  • Hello M.Qassas. Thank you very much for your answer but I can't find "ms-long". I attached the editform – Sharepointnewbie Aug 4 '17 at 14:34
  • </td> </tr> <tr> <td nowrap="true" valign="top" width="113px" class="ms-formlabel"><h3 class="ms-standardheader"> <nobr>Détail du log</nobr> </h3></td> <td valign="top" width="350px" class="ms-formbody"> <!-- FieldName="Détail du log" FieldInternalName="D_x00e9_tail_x0020_du_x0020_log" FieldType="SPFieldNote" --> <span id='WPQ247b34c2e-d223-4965-ad41-c62ef7334e53D_x00e9_tail_x0020_du_x0020_log' data-sp-control='SPFieldNote' data-sp-options='{&quot;mode&quot;:2,&quot;source&quot;:&quot;D_x00e9_tail_x0020_du_x0020_log&quot;}'></span> – Sharepointnewbie Aug 4 '17 at 14:41
  • sorry for late reply, don't do this in the new edit form, do it for the default edit form, so go back to set the old edit form as default and just follow the above steps, please don't hesitate to tell me if you need more clarification, in case my answer worked for you, please mark it as answer , – Mohamed El-Qassas MVP Aug 4 '17 at 19:04
  • Hello M.Qassas. Thank you very much for your help. I tried again this morning and now I can find the "ms-long". But, i have a problem with the following step "Now edit your page, from site setting icon > Edit page" => in fact, my editForm open a new page and so the icon is not reachable. See picture below : [![enter image description here][1]][1] [1]: i.stack.imgur.com/Gxmm5.jpg – Sharepointnewbie Aug 7 '17 at 7:22
  • okay, go to all items page and from the above ribbon from web part, default edit web part see this image, mohamedelkassas.files.wordpress.com/2017/03/form-web-parts1.png also check similar steps do edit to edit form here blog.devoworx.net/2017/03/25/… please don't hesitate to ask me in case you need more clarification and please don't forget to mark my answer in case it helped you – Mohamed El-Qassas MVP Aug 7 '17 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.