2

So I am using SharePoint 2013, and am trying to change the icon for my SharePoint. If I look at it from Office 365, the link to reach it has the icon want: enter image description here

However, the second I follow the link to go to my SharePoint, I end up with this icon instead:

enter image description here

I have tried the solution from here but unfortunately, the look and feel portion of my site won't let me change the icon in any way.

I have changed the siteIcon.jpg file using SharePoint Editor 2013, but that only changed the first Icon, not the Icon you see when you're actually using the website.

What else can I do?


EDIT: I found the problem. They System will reset the Icon every time I log out. Here is the version history:

enter image description here

The System account versions are all the ugly TE, while the ones I put up are all the correct icon...

How can I make the System stop screwing up my icon?

2
  • Are you referring SharePoint online or On-premises? Aug 3 '17 at 19:48
  • @VenkatKonjeti online, the one that comes w office 365
    – Flotolk
    Aug 4 '17 at 16:51
1

Here are steps I have followed.

  1. Go to the SiteAssets library.
  2. You will find a __siteIcon__.jpg file.
  3. Replace your logo with the same name.
  4. Clear cache it does affect. I had the same problem when I updated a logo but (CTRL + F5) get this affected immediately.

enter image description here

8
  • Now you have my settings pages doing what I want them to, but my homepage still acts up...
    – Flotolk
    Aug 3 '17 at 20:04
  • I didn`t think it has to do that initially. But after I inspect the element and took the URL and see the new logo. Then I thought it is an issue with cache same as CSS and JS files. Aug 3 '17 at 20:05
  • So I had to do this from the SharePoint using my internet explorer, not from the SharePoint Editor. For Some reason, it just wasn't getting pushed to the server otherwise...
    – Flotolk
    Aug 3 '17 at 20:17
  • But now every time I exit out of the page, it resets to the default TE
    – Flotolk
    Aug 3 '17 at 20:25
  • I have tested by logout and login from same browser or different browser I see updated logo. Aug 3 '17 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.