I'm working on a Sharepoint 2010 server that is virtualized inside of a domain. The domain controller has Active Directory installed and thus defines the AD Groups on it.

An InfoPath 2010 form was created and installed on the SP2010 server. Inside the form, a number of views were created. Load events were created for each view such that the MemberProfileService Group Name was set as the control. So, users belonging to the Active Directory Inspectors group are only supposed to see the Inspectors view of the form, likewise for 3 other groups.

Unfortunately, the form is not functioning as expected. What must I do to ensure that the domain controller's AD Groups are being used to control view access inside my Infopath form?

Thanks much for any help/guidance.

  • Is this still true? Does anyone know if this is true for Sharepoint 2013?
    – user16322
    Commented Apr 12, 2013 at 14:24

1 Answer 1


This is a known bug/design in SharePoint 2010. There are several posts/articles explaining the issue. Look here for some in-depth discussion. Also, search the thread OP's other postings for more discussion.

Currently, the SharePoint 2010 User Profile Service does not list AD Security Groups as memberships belonging to users. It syncs these groups correctly, as SharePoint is able to apply security with them. However, when viewing a member's MySite profile for example, only Distribution Lists are listed.

The userprofilememberships.asmx web service returns only distribution lists, not security groups. For now, if you wish to apply InfoPath rules based on users' AD memberships, you must utilize distribution lists.

  • Do you know if this applies to mail enabled security groups as well?
    – Lori
    Commented Oct 28, 2011 at 13:33
  • Thanks for your response. Are these distrbution lists created via Central Admin?
    – SidC
    Commented Oct 28, 2011 at 14:43
  • Lori - In my experience it applies to all security groups. SidC - distribution lists are created and maintained in Active Directory.
    – kbeal
    Commented Oct 28, 2011 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.