0

We have Office 2016 and using SharePoint 2013 with SharePoint Designer 2013 32bit on our machines. More recently we are experiencing issues with SharePoint where users are getting below error when trying to create new office document.

'New Document' requires a Microsoft SharePoint Foundation-compatible application and web browser. To add a document to this document library, click the 'Upload Document button.'

In the past we have had similar issue and was fixed by uninstalling 64bit version of SharePoint designer and installing 32bit version of SharePoint designer.

Not sure if the issue is due to the latest security patch installed for SharePoint Designer 2013 (Office 2013: June 13, 2017 (KB3203392))? is it worth uninstalling it or any other workaround ?

  • What is your Office 2016 patch level? – Marek Sarad Jul 31 '17 at 9:42
  • Hi there is no patch installed specifically for Office 2016 as its part of the Office 365 suite. I see the one difference as IE addon shows below ActiveX Control updated from 15.0.4747.1000 to 16 as below, Name: SharePoint OpenDocuments Class Publisher: Microsoft Corporation Type: ActiveX Control Architecture: 32-bit Version: 16.0.8229.2073 – Viral Jul 31 '17 at 9:50
1

We managed to fix it by un-registering OWSSUPP.DLL (the updated version 16.0.8229.2073) for Office15 and re-registered OWSSUPP.DLL which is now (15.0.4747.1000). I hope this will help struggling with similar issue. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.