1

I work for a firm of Solicitors and we store all our Client Care Letters and Terms and Conditions in our Office Manual on our Intranet. It's a Windows Sharepoint Services 3.0 site.

People have to ability to update their departments client care letters etc from the site.

I then need to synchronise these files onto a DFS so they can be launched by our Practice Management System (Pilgrim's Lawsoft).

I was hoping to schedule a batch file to run an xcopy command in the evening just before the DFS relicates.

My problem is I can't find a UNC path to use in the copy command. Are the Documents stored in the database? Is there an easy way to easily copy Documents out of a library? Can I map a drive letter to the Library?

Windows Sharepoint Services 3.0 is running on a Windows 2003 box. The Database is MSSQL2003 also on a Server 2003 box.

migrated from superuser.com Oct 27 '11 at 8:16

This question came from our site for computer enthusiasts and power users.

1

Give this post over on MSDN a try. I have accessed WSS3 libraries via UNC path in the past, so it should be possible. SharePoint won't give it to you, you have to know how to construct the path yourself. You should be able to do \{hostname}{managedpath}{site} which will give you a list of all libraries in that particular site.

  • Yeah I found that article by Googling but it doesn't work. I did turn on the WebClient service as it recommended but no joy. My server is called intranet and \\Intranet shows no available shares for the library. I am unclear what you mean by the path will be \{hostname}{managedpath}{site}. What is the managedpath? and I only have the root site. The URL to the library I want is intranet/Office%20Manual so I assumes the UNC path would be \\intranet\Office Manual – Yeodave Oct 27 '11 at 14:12
  • Is intranet/Office%20Manual the full URL to the library? Do you have more than on web front end, or is this a single server deployment? If this is your URL, then you don't need to worry about the managed path piece. If your site was at say intranet/sites/OfficeManual, then "sites" would be your managed path, so the UNC share would be \\Intranet\Sites\OfficeManual. – webdes03 Oct 27 '11 at 14:37
1

Turns out the WebClient Service had to be running on the Client, I had turned it on on the Server. I also had trouble with the WebClient service being stuck on stopping. I solved this by adding a new Reg Key:

Local Machine\System\CurrentControlSet\Services\WebClient\Parameters

Added a DWORD called UseBasicAuth and set it to 1

\\Intranet\Office Manual then worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.