1

I'm not able to get the built-in auditing to keep more than 24 hours of records. I have auditing enabled on the site collection, and turned off auto-trim (originally set to trim at 7 days). I don't have any 3rd-party add-ons installed, and I've verified that there are only approx 24 hours of records in the AuditData database table at any given time (sometimes slightly more).

Also, the setting to disable auto-trim keeps getting reset to Yes after some period - approximately the same time the audit logs are trimmed. Logs are definitely not being kept for 7 days, as the setting defaults to.

In Central Admin, Audit Log Trimming is set to monthly, and I don't see any additional timer jobs related to auditing.

I'm the only site collection admin, but something is overriding my settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.