I am attempting to search Exchange public folders via SharePoint Enterprise Search. I have a content source pointing at my exchange server, and this successfully indexes some emails.

However, any email that has an attachment fails to index, with the following error:

"Error while crawling LOB contents. ( The request failed with HTTP status 401: Unauthorized. )"

So far I've tried TXT and DOCX attachments, but get the same error on both

Can anyone suggest why this is? I've spent many hours trying to resolve this, with no success.

FYI, I am not using SSL to connect to Exchange from sharepoint, nor is Kerberos in use.

Many thanks Gerry

1 Answer 1


The crawler is using the default content access account to do this. It seems that it don't have access to your Exchange Public folders. If you defined other way of authentication in the Content type crawl rules, you need to ensure that you can authenticate to the email AND the attachment with that very user.

  • Thanks for the response. However, in this case I've set up a crawl rule to use an administrative account to do the crawling on the exchange box, which I would have though would have the same authority to access the document within the email as the email itself. If not, how would I go about giving permissions to attached documents, which are presumably stored within the public folder database? Thanks again Gerry
    – Gerry
    Oct 27, 2011 at 9:08
  • Your crawler itself ought to have the highest access rights. When you set up a federated search / result source (if you're using SP2013) that is when you define whether to use the default account for results or the user's Windows account. Sep 1, 2013 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.