I have created a custom list (Department Contact List) in SharePoint which will be added as a webpart to different pages. So the list shows only the information relating to the page it is on. I have modified the view of the webpart. However, when I save the page the List Name (Department Contact List) has become a hyperlink. Is there any way to stop this from happening? Not only does it not look great but It may confuse people.

3 Answers 3


I am not 100% sure if I got your requirement right.

You can remove the title of the custom list from the page from 'Appearance' Just add a blank space and ensure that Toolbar Type is set to 'No Toolbar'. The result will be something like this:

enter image description here


Unfortunately, there's no way that I know of to simply remove the link. You can modify the link, or you can remove the title completely.

To modify the link, edit the page, and get to the web part properties. From there, go to Advanced --> Title URL, and change it as desired. If you simply delete whatever is there, I believe that SP just resets it to the default, so perhaps change it to the URL of the page it's on, or any other more appropriate URL.

To remove the title completely, and get to the web part properties. From there, go to Appearance, and change "Chrome Type" to "None". A common hack people do with this is they add text right above the web part to act as a title. Depending on the version of SP you're using and which page layout is in use, you can either type text directly above the web part, or you can add a content editor web part right above the list web part.

  • You can also just put # in the Title URL and it will still behave like a link (i.e. it will still underline and change the pointer) but clicking on it won't take you anywhere and nothing will happen. Commented Jul 12, 2017 at 22:07
  • 1
    I tested that this morning on O365, but it didn't work.
    – Mike2500
    Commented Jul 12, 2017 at 22:29
  • Really?? I tested it on SP2010 before I commented to make sure and it worked fine. Interesting that they would change that.. Commented Jul 13, 2017 at 16:29
  • In my test, it links to /sitepages/%23. %23 is the URL encoding for #
    – Mike2500
    Commented Jul 13, 2017 at 18:11

If what you are talking about is the webpart's title taking people to the custom list, the only way I have effectively addressed that is to change the Chrome for the webpart's appearance setting from "Default" to None or Border only and then adding a content editor webpart above it and type in and format the title I want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.