0

I am installing a SP2013 Dev instance. I have SQL 2012 and SP2013 on the same machine. I don't have reporting services installed but I did add the SharePoint reports service option during SQL installation.

During AutoSpInstaller installation I am getting this warning:

WARNING: Feature PowerView\Feature.xml had failed to install for the following reason: Failed to create receiver object from assembly "Microsoft.ReportingServices.SharePoint.UI.ServerPages,Version=11.0.0.0,Culture=neutral,PublicKeyToken=89845dcd8080cc91", class "Microsoft.ReportingServices.SharePoint.UI.PowerViewSiteFeature" for feature "PowerView" (ID: bf8b58f5-ebae-4a70-9848-622beaaf2043).: System.ArgumentNullException: Value cannot be null.
Parameter name: type
   at System.Activator.CreateInstance(Type type, Boolean nonPublic)
   at System.Activator.CreateInstance(Type type)
   at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject().
WARNING: Feature ReportServer\Feature.xml had failed to install for the following reason: Failed to create receiver object from assembly "Microsoft.ReportingServices.SharePoint.UI.ServerPages,Version=11.0.0.0,Culture=neutral,PublicKeyToken=89845dcd8080cc91", class "Microsoft.ReportingServices.SharePoint.UI.ReportServerFeature" for feature "ReportServer" (ID: e8389ec7-70fd-4179-a1c4-6fcb4342d7a0).: System.ArgumentNullException: Value cannot be null.
Parameter name: type
   at System.Activator.CreateInstance(Type type, Boolean nonPublic)
   at System.Activator.CreateInstance(Type type)
   at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject().
WARNING: Feature ReportServer\Feature.xml had failed to install for the following reason: Failed to create receiver object from assembly "Microsoft.ReportingServices.SharePoint.UI.ServerPages,Version=11.0.0.0,Culture=neutral,PublicKeyToken=89845dcd8080cc91", class "Microsoft.ReportingServices.SharePoint.UI.ReportServerFeature" for feature "ReportServer" (ID: e8389ec7-70fd-4179-a1c4-6fcb4342d7a0).: System.ArgumentNullException: Value cannot be null.
Parameter name: type
   at System.Activator.CreateInstance(Type type, Boolean nonPublic)
   at System.Activator.CreateInstance(Type type)
   at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject().
  • In which section of AutoSPInstaller did you get the warning? – MHeld Jul 12 '17 at 12:10
  • I get this warning right after the config database is created. It can't find a related section in the input file where something is done with PowerView – Danny Jul 12 '17 at 12:11
  • I've never installed a DEV-VM with SharePoint integrated Reports on the same box. Might be a problematic combination. Do you need Reports? – MHeld Jul 12 '17 at 12:24
  • No I don't need it. I am now trying to install without the SharePoint reporting server. – Danny Jul 12 '17 at 12:33
  • Installing when no reporting server for SharePoint is installed the error doesn't appear. So it seems you can not host on same server – Danny Jul 12 '17 at 18:52
0

An AutoSPInstaller-Installation with installed Reporting-Services in SharePoint Integrated Mode seems to be a problematic combination if everything is installed on one machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.