2

Looking around I know this is a common error but I can't find for help for the specific issue I am having.

I am getting the error but in the message it is displaying the web part with it's assemblyFullName$ twice. I.E.

Web Part Error: A Web Part or Web Form Control on this Page cannot be displayed or imported. The type External.UI_External.UI_External, External, Version=[redacted], Culture=neutral, PublicKeyToken=[redacted] could not be found or it is not registered as safe.

I have verified that it is in the Safe Control Entries, it is in the Web.Config, and it is getting copied to the GAC with the name of UI_External. The PublicKeyToken and version number match everywhere. I've tried manually updating through the Safe Control Entries to have the assemblyFullName twice to try and match what the error is apparently looking for and this does not help fix anything.

  • When on your page, add ?contents=1 to the page's URL. This should list all of the web parts in the page. Can you see duplicates of your web part, or anything else that shouldn't be there? – moe Jul 12 '17 at 10:50
  • There are no duplicates when I view the contents, it does bring it up in the contents as Web Part Title: "Error" and Type as "ErrorWebPart" so I'm not sure if it's getting far enough to provide us anything useful. – user2542930 Jul 12 '17 at 13:30
0

As per your error message:

  • External.dll is the name of your assembly SharePoint looks for, not UI_External.dll. This basically means you tried to instantiate your Web part (via code or with an XML file in your solution) by referencing the wrong DLL name.
  • The namespace your Web parts relies in is External.UI_External.
  • The class name of your Web part is UI_External (thus its full name is External.UI_External.UI_External: is it correct, or is there also an error here?

I strongly suggest you to carrefully review the names of your project/assembly/namespaces/classes and be sure they're all set correctly.

  • Thank you Evariste, I'm looking into all of that now. Sorry if I provided inaccurate information. This case got tossed on me with not a whole lot of Sharepoint experience so I appreciate your detailing of what exactly everything is. – user2542930 Jul 12 '17 at 13:52
0

Whenever you install a web part (in custom solution i.e. .wsp) into farm using PowerShell or Central Administration it creates a safe control entry in web.config file of the web application. The safe control entry looks like following:

<SafeControl Assembly="StackExchangeTest, Version=1.0.0.0, Culture=neutral, PublicKeyToken=1b0473841e50f1dc" Namespace="StackExchangeTest.WebParts.TestUpdatePanel" TypeName="*" Safe="True" />

Try to search your web part entry in web config file. In cases, when you save site template from web application and try to use in different web application you can face this issue. Or sometimes, people download the .webpart file from web part gallery and upload them to different web application which results in Not a Safe Control issue.

  • Thanks for the input but I have already confirmed that it exists in the web.config as a SafeControl. – user2542930 Jul 12 '17 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.