A user added a new post to a discussion board. It is not showing up under 'Recent', but it is under 'My discussions'. I tested it by creating a new post and same thing.

It appears pressing the 'new discussion' button is bringing up a form but it is not the discussion form (URL is missing the ContentType and RootFolder params).

How do I make the discussion content type the only default content type?

Edit: Discussion is set as the default type. enter image description here

If I use the ribbon and select New Item, the discussion form is used. Only the new discussion button at the top of the thread is loading an alternate form (don't even know which one, don't think it is the message form)

Edit2: Image of form when clicking new discussion. Note lack of Question data type. enter image description here

1 Answer 1


In the discussion board, by default, the discussion content type is the default one as shown below.

enter image description here

How do I make the discussion content type the only default content type?

  • Go to List Settings > below Content Types.

  • Click on Change new button order and default content type as shown in the above image.

  • At Position from Top drop-down, chose 1 where The first content type will be the default content type.

  • In case, you need it as the only content type, just uncheck visible for other content types.

  • Thanks for the prompt reply. I updated the question with some more information. I do have the Discussion set as the default but I actually don't have the option to change the order or default. I don't think I can on any Discussion Board.
    – anonymous
    Commented Jul 11, 2017 at 19:40
  • do you have any customization? share the form that loaded with new disscu button, also if it's SharePoint online please remove 2013 to can specify the sp version! Commented Jul 11, 2017 at 19:45
  • Updated question with form and removed 2013 tag
    – anonymous
    Commented Jul 11, 2017 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.