1

I have a single server sharepoint 2010 farm (Database-SQL server 2008 R2, SharePoint server 2010 both installed on the same server)

This morning, we started patching the SP 2010 by installing the SP 2010 service pack 2 first and then the June 2017 CU. All went well.

Now time to run the SharePoint Products Configuration wizard to upgrade the farm. Running the wizard throws up an error

Internet information services not installed. You must have Internet information services installed to run the SharePoint Products Configuration wizard

I opened IIS manager and there Internet information services is installed and running!

I try to open SharePoint Central Admin and it opens.

Still, i am not able to run the SharePoint Products Configuration wizard because of the error.

I will appreciate any help on this. Thanks in advance.

2
  • Please have a look to your Windows Services console.
  • Maybe the "IIS Admin Service" has startup type "Disabled". Set it to automatic and start the service.
  • Just to make sure: Perform an IISRESET
  • Start Products Configuration Wizard again
  • I guess IISRESET should work.. – Aakash Maurya Jul 11 '17 at 10:34
  • 1
    Thanks alot for the reply. I tried starting the IIS Admin service, it failed to start. Tried IISRESET, it failed. Then I followed the instructions here experts-exchange.com/questions/24546925/… . That solved the IISRESET and IIS Admin Service issues. then I ran the configuration wizard again. this time it succeeded. Thanks alot. – Ehizo Jul 11 '17 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.