1

Using SP Designer, I created custom forms for my list on Sharepoint online. Basically, the forms are same as default forms but with an added CEWP on the page. Unfortunately, the nice UI that comes with Sharepoint disables as soon as you do that. But that's fine.

Now when I try the site on a mobile device, and I go into the list form, I do not get the form. Instead I get a page that says "The page you selected refers to a view which is not enabled for mobile devices".

I understand that a user using a mobile device can switch to the PC view to see my form. But how can I enable a custom list form for viewing on a mobile device so the user of my form would not need to switch to the PC view?

  • Try in the list settings and views (last option "Enable this view for mobile access" is ticked – SharePointer Jul 11 '17 at 13:27
  • @SharePointer, I'm afraid that applies for a view, as opposed to a form (e.g. NewForm, EditForm, DispForm). – Frank Fajardo Jul 11 '17 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.