0

*.txt files are opening in browser for all users. Is there a fix on the server level so that *.txt files are prompted to open in Notepad?

The default association for such file types on the system is Notepad already.

1

There is a dated answer stating that this is not possible. However you could try the following:

  • In your SharePoint's Central Administration, Confirm that Browser File Handling is enabled at Manage Web Applications > General Settings.
  • Then, on your site collection's root, confirm that the site collection feature for Open Documents in Client Applications by Default is enabled.
  • Finally in your local Windows, confirm that the default program used to open .txt files is Notepad.

After confirming these, open Notepad in Windows. Go File > Open, and in the file selection window write the address to a path where you have a .txt-file hosted in SharePoint (e.g. http://site/Documents/file.txt). After you have the .txt-file opened, you can close your Notepad, and restart your browser. By doing the file opening once this way, .txt-files may now be prompted to be opened with a client program (i.e. Notepad) when they are opened in SharePoint. I'd expect that the best results are achieved by using IE.

This was suggested in here: https://sharepointmaestra-public.sharepoint.com/Blog/Post/37/Opening--txt-Files-in-NotePad

Other than that I don't think there are many options for opening .txt-files in client programs directly through SharePoint. You can always open the file hosted in SharePoint by pasting its full URL to the file explorer's address bar though, but that's still quite manual approach.

  • You would need to accomplish this via MIME types in IIS. There are no SharePoint settings that would impact this behavior. – Trevor Seward Jul 11 '17 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.