2

I'm having problems connecting to a SharePoint online site. I did remove my account in SPD (see image), to be able to add another. But after this, I can't even add another account. It immediately pops up the error message

We are unable to connect right now. Please check your network and try again.

I get same error message if I try I connect to my sp online site as well, together with the message

"You do not have permission to open this website in SharePoint Designer"

enter image description here

  • 1
    is it the first time you have tried to login to SharePoint online using SPD? – Mohamed El-Qassas MVP Jul 10 '17 at 18:00
  • Yes, this is the first time Im using SPD for this (virtual) computer. When I looked at the account I was logged in as my ("personal" )msdn-account. I tried a few times, and then removed that account. – Cowborg Jul 10 '17 at 18:39
2

Regarding the #1 Issue

"You do not have permission to open this website in SharePoint Designer"

  • Maybe because you are trying to login to SharePoint online with your MSDN account that doesn't have access to this site.

  • Make sure that the scripting capability settings has been enabled at

    • Office 365> Admin > Admin Center > SharePoint > Settings.

enter image description here


Regarding the #2 Issue

We are unable to connect right now. Please check your network and try again.

  • Make sure that you already have internet access.
  • Make sure that you have

  • Make sure that the Internet access icon beside the Sound Icon at taskbar don't have warning or error "No Internet access" despite you can access the internet

    • In case you have any warning or error "No Internet access" try to disable your Local Area Connection at Network and Sharing Center then wait a moment then enable it again.
    • In case the issue still persists, try to enable by set the EnableActiveProbing to 1 in Registry at the below path.

          HKEY_LOCALMACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc
          \Parameters\Internet\EnableActiveProbing
      

enter image description here

  • Hi M. Qassas! Thanks for taking your time :) . Ive set the permissions in CA (but no difference) , and regarding the user account. I suspected the same thing and removed my own account to replace it with one that had access to this tentant, but now I cant add any account at all, it immedeately gives me that error message. When it comes to the internet access symbol your right, the icon says its disabled even though its enabled. I cant get it to be enabled though. My EnabledActiveProbing was already set to 1. – Cowborg Jul 11 '17 at 7:35
  • The trick in internet icon that should be shown without any issue so do you try to do the following as i mentioned in above answer In case you have any warning or error "No Internet access" try to disable your Local Area Connection at Network and Sharing Center then wait a moment then enable it again. – Mohamed El-Qassas MVP Jul 12 '17 at 13:11
0

Make sure all updates for SharePoint Designer and Office 2013 SP1 are applied.

Same error for me on a new install of Sharepoint Designer 2013 connecting to a SP2016 site.

Our IT group does not release Important and Optional Windows updates. I found half a dozen SharePoint Designer related updates waiting in Microsoft Update. I applied them, rebooted and I'm able to connect now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.