3

I get Error when Deploy that SharePoint App

Error 1 Error occurred in deployment step 'Install app for SharePoint': The System Account cannot perform this action.

enter image description here

5
  • yes but this solution is not worked for here.. Commented Jul 6, 2017 at 11:34
  • try this once sharepoint.stackexchange.com/q/68419/30145 Commented Jul 6, 2017 at 11:34
  • 1
    I also see this article but it is also not worked Commented Jul 6, 2017 at 11:36
  • What account are you using to to deploy the app? Are you RDP'ing into the server with that same account? Commented Jul 6, 2017 at 11:54
  • same account using administartor Commented Jul 6, 2017 at 12:05

1 Answer 1

2

Try it with another account other than the Admin account but with farm account similar privileges. The default admin account is treated as the system account and it will not allow apps to be added or removed via the system account.

Ideally, when setting up your environment, you should be using a system account (part of admin group) to login to the server but setup SharePoint using a farm account (farm admin and run all the app pools)

1
  • I try this but not worked it.. Commented Jul 6, 2017 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.