I wanted to remove the existing search service applications in my SP 2013 Farm. For that I directed my juniors to delete the same from central admin, but they could not delete. The entries were still there. So, they went to Sql Server and deleted all the search service application related databases using Sql Management Studio.

Now, when they came back to central admin, manage service applications page, all the search service applications were still available . When they tried to Delete the same again, but got another kind of error.

Sorry, something went wrong Cannot open database "Search_Service_Application_DB_a995b3c88ca94d63963387a519011088" requested by the login. The login failed. Login failed for user 'mydomain1\mmuser1'

How to resume deleting the same Search service applns from Central Admin.

  • 1
    Deleting a service application by brutally deleting the db is the same as you'd delete an installed software on your computer by going to C:\Program Files\ and deleting a folder named by the software. Hint: the result is not what you wanted. In order to advance on this, please share (1) the errors the CA shows, and (2) how exactly you are attempting to delete the service application at the CA.
    – moe
    Commented Jun 28, 2017 at 11:58
  • sorry,actually it was not done by me, :-( it was deleted by another junior team member.
    – samolpp2
    Commented Jun 28, 2017 at 12:40
  • Sorry, something went wrong Cannot open database "Search_Service_Application_DB_a995b3c88ca94d63963387a519011088" requested by the login. The login failed. Login failed for user 'mmydomain11\mmuser1'
    – samolpp2
    Commented Jun 28, 2017 at 12:41

3 Answers 3


Try the following steps using PowerShell to remove the search service application:

  1. Get-SPServiceApplication
  2. Identify the GUID for the search service application and take a copy of it.
  3. $SSA = Get-SPServiceApplication -identity "GUIDRetrievedAbove"
  4. Remove-SPServiceApplication $SSA

If that doesn't work, try the following instead:

  1. $SSA = Get-SPEnterpriseSearchServiceApplication -id "GUIDRetrievedAbove"
  2. $SSA.Unprovision(1)

If that doesn't work, you can replace the last line above with


If all else fails, you can try STSADM:

stsadm -o deleteconfigurationobject -id "GUID"

"GUID" is the ID of the Service Application.

You can get the IDs of all service applications by running the following PowerShell command :


I am having the same issue and just cannot resolve it. Can someone please help? The command

Get-SPEnterpriseSearchServiceApplication -id 1374d71a-10a2-4b72-83bd-e1bb1efa9675

gives the following error message:

format-default : Exception has been thrown by the target of an invocation. + CategoryInfo : NotSpecified: (:) [format-default], TargetInvocationException + FullyQualifiedErrorId : System.Reflection.TargetInvocationException,Microsoft.PowerShell.Commands.FormatDefaultCommand

I tried all the suggestions out there but nothing seems to work. I cleared the config cache, recycled timer service, tried to delete through CA, Powershell - everything but the service application is still there. I am now unable to create another Search Service Application.

Thank you in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.