7

I have a super weird problem in a SharePoint online environment.

Yesterday I was doing some testing, and I added a javascript alert on the masterpage for 5 minutes and removed it thereafter. This morning I got a call from one of the users telling me how she's seeing this weird alert when accessing every page. Needless to say this is restricting her from working.

I tried various things but at the end got to the conclusion that any changes that I am affecting to the master page, are being updated on every account but hers. This is neither a cache nor a browser problem. I tried on different browsers and on different computers. It seems that SharePoint is caching the master page for that particular account. I also tried changing the master page. Naturally the alert does not show on the different master page but comes back again when reverting back to the actual master page.

But this does not add up! I don't know where to start from. I cannot delete the user and start again as this is a work email with a lot of important mail!

  • Is it a custom masterpage or default masterpage? – Aakash Maurya Jun 23 '17 at 10:48
  • It is a default master page with some styles and scripts referenced into it. It is the Seattle one – Jurgen Cuschieri Jun 23 '17 at 10:51
6

As I think this is the problem with Check-in and Publish problem.

I hope you have Checked-In the Masterpage and published it again. Any changes to Masterpage requires this operation.

While publishing the masterpage or any publishing page you will have two options.

  • Publish as Minor Version(Draft)
  • Publish as Major Version

Major version publish is always considered as final version and it is available to all users(Changes done in masterpages will now reflected to all users)

You can find the point to point difference between these here

So that might be an issue

  • Thanks for your reply. I have checked out and checked in. I have also tried to revert to an earlier version than yesterday. Also, I have the check out and check in functionality in SharePoint designer but not publish – Jurgen Cuschieri Jun 23 '17 at 10:53
  • 2
    Also, logically, if the master page is not checked in and not published, the update should not be reflected on any user account and not just this one – Jurgen Cuschieri Jun 23 '17 at 10:53
  • Totally agree. Let me try regenerating it at my end.. – Aakash Maurya Jun 23 '17 at 10:58
  • 1
    Thanks Aakash, I noticed that there was the option to publish a major version and even though I do not think it makes sense that only one user was experiencing the problem, it managed to fix it for me! – Jurgen Cuschieri Jun 23 '17 at 11:24
  • Whenver we change anything in masterpage we have to pubhish it as a Major version. Glad you pointed out the thing and got solved :-) – Aakash Maurya Jun 23 '17 at 11:26
1

I managed to fix the problem. As pointed out by Aakash it required to be published. What is strange is the fact that only one user experienced the problem from the 4 using the system at the same time. A possible but unlikely explanation would be that at that 5 minute period where the alert was live on the master page, this user was the only one who accessed the system.

Also normally, a check out when editing and check in once ready is sufficient. To publish, I right clicked on the master page from the Master pages section in the SharePoint Designer. Among the options there is;

  1. Check in a Minor version
  2. Publish a Major version

Publishing a Major version solved the issue for me.

0

I hade similiar issues with our Masterpage.

To me it was the minimal download strategy feature.

Please check if your MDS Feature is deactivated at every web page.

To deavtivate the feature on every page, i wrote a simple PS-Script:

    Add-PSSnapin Microsoft.SharePoint.PowerShell –ErrorAction SilentlyContinue

    #SharePoint web App URL
    $WebAppURL ="URL_TO_SP"
    $FeatureName ="MDSFeature"

    #disable the MDS for all web applications
    $WebsCollection = Get-SPWebApplication $WebAppURL | Get-SPSite -Limit All | Get-SPWeb -Limit All

    foreach($web in $WebsCollection)
    {
        #Check if the feature is activated
        $MDSFeature = Get-SPFeature -web $Web.Url  | Where-object  {$_.DisplayName -eq $FeatureName}

        if($MDSFeature -ne $null)
        {
            Disable-SPFeature –identity $FeatureName -URL $web.URL -confirm:$false
            write-host "Minimal Download Strategy Feature has been disabled at: "$web.Url
        }
    }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.