0

When I install @microsoft/generator-sharepoint, I get below error. Kindly note that my node version is v6.11.0 and npm version is 5.0.3 enter image description here

What can be the issue.

1

Make sure that you have the latest version of NodeJS. You can check the latest version using

node -v

Follow the full procedure here: SharePoint Framework - Set up your SharePoint client-side web part development environment

  • Ronak please read my question. BTW I have latest node and npm but I have issue @microsoft/generator-sharepoint – Milind Jun 22 '17 at 4:32
  • Yeah.. but make sure that you are following all the steps in the link above. Thanks.. – Ronak Patel Jun 22 '17 at 4:53
1

SPFx build pipeline does NOT currently support npm v5.x, so you'll need to use either v3 or v4. At the time of the writing, NodeJS LTS version (v6.11.0) installs npm v3.10.10.

You can downgrade to older npm version with following command npm install -g npm@3.

You can check below SPFx article for complete details

https://github.com/SharePoint/sp-dev-docs/blob/staging/docs/spfx/set-up-your-development-environment.md

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.