0

I have a fresh installation of SharePoint Server 2016 on-premises with Project Server 2016 enabled. I've followed the Technet documentation to create my first PWA site. However, when I load the Project Center page (/Projects.aspx), I get a blank page. There are no errors thrown to the screen, but I see the following in Fiddler:

The resource token(s) 'LIBRARY_ACTIVEXVIEWPART_PROTOCOL_LENGTH_LIMITATION_FOR_OPEN_PROJECTS_ALERT,LIBRARY_ACTIVEXVIEWPART_PROTOCOL_LENGTH_LIMITATION_FOR_OPEN_RESOURCES_ALERT' referenced in ../config/resources/PWA.resx.scriptx could not be found in ../config/resources/PWA.resx

Hunting down those files and opening them reveals that both tokens specified above are where they need to be. I deleted and re-created another PWA instance and still got the same result.

Any suggestions?

  • Am also facing similar kind of issue. After installing SP 2016, when I got to project center and 'Project' ribbon above then I see all the options like 'New Project' and all as inactive. Also I don't see any projects on project center when I publish them from MSP, however I can see them in SQL in associated content DB .Please give me any suggestion – PallavN Jun 27 '17 at 11:46
  • 1
    Is it SP 2016 RTM? what about the other PWA functionality. Is it working? – Mohamed El-Qassas MVP Jun 27 '17 at 11:59
  • @PallavN - Were you running a fully patched version of SharePoint? I ended up uninstalling and re-installing the farm without applying the June 2017 CU patches that I applied the first time around. I re-installed and applied the May 2017 CU and have since not experienced an issue. I only had an issue with the webparts in the Project Center. – Eric Paulsen Jun 28 '17 at 15:11
2

We had the same issue since the last CU of SharePoint Server 2016 (CU of June 2017).

enter image description here

After 10 days of digging, we could find that the issue is related to some resx files. In our case, PWA.en-us.resx has not been updated:

resx file has not been updated

So in the Fiddler, we saw following error:

The resource token(s) 'LIBRARY_ACTIVEXVIEWPART_PROTOCOL_LENGTH_LIMITATION_FOR_OPEN_PROJECTS_ALERT,LIBRARY_ACTIVEXVIEWPART_PROTOCOL_LENGTH_LIMITATION_FOR_OPEN_RESOURCES_ALERT' referenced in ../config/resources/PWA.resx.scriptx could not be found in ../config/resources/PWA.resx

Finally, we could solve the issue by replacing PWA.en-us.resx file with PWA.resx file , in ..\Common Files\microsoft shared\Web Server Extensions\16\CONFIG\Resources Folder.

Hope this can help you.

  • 1
    Thanks Amir -- those messages were similar to what I was seeing in my environment. I ended up staying with the May CU for the time being. I see that Microsoft has since released the July CU. Not sure if I am going to try it out because attempting to roll back a bad patch is not something I want to take on right now! – Eric Paulsen Jul 17 '17 at 19:37
1

I ended up un-installing and re-installing my SharePoint farm without applying the June 2017 CU patches that I applied previously and all functionality was restored to PWA. I applied the May 2017 CU patches yesterday and have not had any problems as of yet with a fresh instance of PWA + a restored instance from a Project Server 2013 installation.

0

Confirmed, I had the same issue after upgrading to the August 2017 CU. We usually only update quarterly, so I skipped the June Update. I'm testing out the Sept 2017 CU in our Stage environment now, but not seeing the issue there. I went straight to Sept CU in Stage, though. Opening a bug case with Microsoft on this.

-1

After update Wssloc2016-kb3203433-fullfile-x64-glb this update showing error

Server Error in '/' Application. Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

Details: To enable the details of this specific error message to be viewable on the local server machine, please create a tag within a "web.config" configuration file located in the root directory of the current web application. This tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's configuration tag to point to a custom error page URL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.