I have installed VS 2017 with SharePoint Designer 2013 32 bit and when i configure workflow manager, i get this error: server side activities have been updated you need to restart sharepoint designer.

Most of the blogs suggested to uninstall Workflow manager client from Control panel - Programs , but i didnt see it listed there but when i open Web platform installer, i see it installed on my machine.

up vote 2 down vote accepted

You need to install the January 12, 2016, update for SharePoint Designer 2013 (KB3114337). it fixes that issue:

When you try to create a SharePoint 2013 workflow in SharePoint Designer 2013 on a computer that has Microsoft.Activities.dll installed, you receive the following error message: Server-side activities have been updated. You need to restart SharePoint Designer to use the updated version of activities.

Before installing this package you must first install the prerequisite Microsoft SharePoint Designer 2013 Service Pack 1.

https://support.microsoft.com/en-us/help/3114337/january-12--2016--update-for-sharepoint-designer-2013-kb3114337

Symon's approach didn't help me. So here's what I followed and it resolved the issue. Clear cache from below locations

  1. %APPDATA%\Microsoft\Web Server Extensions\Cache

  2. %APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache

  3. %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache

  4. C:\Users\username\AppData\Roaming\Microsoft\SharePoint Designer

• Now uninstall SharePoint Designer • Reboot and then re-install in below order.

Order of installation 1. SharePoint Designer 64-bit (sharepointdesigner2013_64bit.exe) File Version: 15.0.4420.1017

  1. SharePoint Designer Service Pack 1 (spdsp2013-kb2817441-fullfile-x64-en-us.exe) File Version: 15.0.4569.1506

  2. Security Update for Microsoft SharePoint Designer 2013 (spd2013-kb2863836-fullfile-x64-glb.exe) File Version: 15.0.4615.1001

  3. Update for Microsoft SharePoint Designer 2013 (spd2013-kb3114337-fullfile-x64-glb.exe) File Version: 15.0.4787.1000

  4. Update for Microsoft SharePoint Designer 2013 (spd2013-kb3114721-fullfile-x64-glb.exe) File Version: 15.0.4849.1000

Have tried to download all MS update files and SP1, what eventually worked to not have the "server-side..." erro was

  • Uninstall Visual Studio
  • Open the site I need access to in SPD on IE11 first (must be IE11 if work security is authenticated through IE11 as main), then open the site in SPD, and the workflow was able to download through web service onto local cache

Removing Visual Studio 2017 resolved the issue for me using SharePoint Designer (32 bit).

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.