2

I have tried to install a couple of 3rd party apps available in the 'Apps you can add' section of the app library - News Add-in by KEMBIT and Spotlight Announcements.

I clicked install one after the other and the initially seemed to take a long time saying they were installing so I left them over night as this had worked with another app I had installed. I realized the next day that they still had not installed and only one was showing in the standard sites content view, but was greyed out.

It said there was an error with the install, so I click the retry option - no joy. Upon navigation to the classic view I find the other app also has the same issue - I click the retry install several times on both but it just comes up saying it has had an error with the install again.

So I try clicking the delete/remove option to start afresh and it says it is unable to remove either app. I am now stuck with two apps I can neither use or get rid of. Has anyone had the same issue and found a resolution?

1
  • In addition I have attempted install of the KEMBIT News Add-in on another sub site in the same collection and the install works fine, so can conclude that it may have been trying to install two apps at the same time which may have caused the issue. However still don't know how to solve getting the crashed ones off the original site?
    – RMcIntosh
    Commented Jun 21, 2017 at 10:37

1 Answer 1

0

By looking at the tags related to your question, I presume that you are working in O365 SP Online environment. Since app removal is not working from front end then you should try using powershell commands. You can reach out to your Office 365 tenant admin (OR who has permission to run powershell commands). Please refer this MSDN link:

https://technet.microsoft.com/en-IN/library/fp161233.aspx

2
  • Thanks DvG this is most helpful. I suspected it was something I was going to have to get IT Admin to help with, since I don't have back end access - at least I can advise them now. Not sure why Microsoft wouldn't allow you to delete front end though - seems daft that this doesn't work properly!
    – RMcIntosh
    Commented Jun 21, 2017 at 11:58
  • Actually MS allows from front end but because of some deployment/installation errors in apps we have to rely on powershell commnds
    – DvG
    Commented Jun 21, 2017 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.