0

i have a problem, sorry for my english. I have a virtual server where I have installed SharePoint 2013 Enterprise, SQL Server 2012 R2 and Visual Studio 2013. When opening visual studio 2013 and trying to create a sharepoint solution, this one displays me an error box, stating "Can not connect to the target site, this error can occur the specified site not being hosted on the local system." . And I can not find the solution, if you need additional information, I can add it in the question enter image description here

1

You've got a hypen in your URL (spc-sharepoint**-**:8080). Remove that and try again.

EDIT: You need to modify the hosts file at C:\Windows\System32\drivers\etc\hosts with the line:

127.0.0.1 spc-sharepoint-

  • The character '-' is part of the server name – Ariel Ignacio Jun 20 '17 at 15:38
  • The next step would be to add a hosts file entry in the format of 127.0.0.1 spc-sharepoint- on the SharePoint server itself. – Trevor Seward Jun 20 '17 at 15:40
  • Sorry, have to add the ip 127.0.0.1 or ip from the same server (10.10.1.1xx) ? – Ariel Ignacio Jun 20 '17 at 15:57
  • You need to modify the hosts file at C:\Windows\System32\drivers\etc\hosts with the line: 127.0.0.1 spc-sharepoint- – Trevor Seward Jun 20 '17 at 15:58
  • 1
    It doesn't require a restart, but you should close out VS and reopen it after making the change. – Trevor Seward Jun 20 '17 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.