3

I'm currently working with an associate who is unable to add the Content Editor web part to a specific SharePoint page in the environment. The specific site that the user needs to do this on is a sub-site, so I made sure to stop inheriting permissions from parent site, and add the user with design permissions to the specific sub-site permissions list. I made sure that the user has the design permission to do so, since that is the permission that allows a user to Add and Customize Pages, but they are still unable to do so. Is there anything I am missing in the process?

The exact error message reads: "A Web Part or Web Form Control on this Page cannot be displayed or imported. You don't have Add and Customize Pages permissions required to perform this action."

  • Is there any specific error message that you are getting ? – Rohit Waghela Jun 20 '17 at 12:30
  • The user gets and error that says "You do not have Add and Customize Pages permission to perform this action". But on the Microsoft support site, it says that the Design permission includes that. – SamB. Jun 20 '17 at 12:32
  • is this SharePoint online or On premise ? – Gautam Sheth Jun 20 '17 at 12:52
  • @GautamSheth we are on premises – SamB. Jun 20 '17 at 12:55
  • My observation on SPO site is Design permissions are sufficient to make changes to Site Page but not to the publishing page. I think this behavior should be same for SP 2013 also. Which page is you are editing? – Venkat Konjeti Jun 20 '17 at 13:10
2

Try checking the permissions of the webpart gallery at your site collection root:

or

site settings > Under Galleries > Master pages and page layouts > Permissions

http://example.org......./_catalogs/masterpage/Forms/AllItems.aspx

  • I tried following that path and was able to get to Master pages. There was nothing listed within "Master Page Gallery" that was called Permissions. Could it possibly be named something else? – SamB. Jun 20 '17 at 20:14
  • The link path provided in your edit also takes me to the same place. There is nothing in the Master Page Gallery labeled "Permissions" – SamB. Jun 21 '17 at 17:49
  • Because of the fact that my code works fine in DisplayMode of a page, I surrounded my code with the following condition: if (SPContext.Current.FormContext.FormMode.Equals(SPControlMode.Display)) { //Populate the "innocent" label } The condition will check whether you are in DisplayMode are not... If so... populate the label. – Mathew Jun 22 '17 at 14:55
1

We need to have "Add and Customize Pages" permission to add the "Content Editor" web part. However, as Add and Customize Pages permission is not included in the default "Contribute" permission level, so it is expected that the users can't add this web part.

We can add the "Add and Customize Pages" permission to a customized permission level and assign the permission level to the users. You can follow these steps and check whether they can add this web part:

  1. Go to the affected site > Site settings > Site permissions > Permission Levels > select the default "Contribute" permission level > scroll down to the bottom and click "Copy Permission Level" > give it a name, for example "my permission".

  2. Scroll down to Site Permissions section, tick "Add and Customize Pages" > create.

  3. Go back to Site permissions page > select the users > Edit User Permissions > choose the permission we just created > OK.

  4. Let the user sign out and sign in to the site and check the result

  • In this case, I don't need to create a custom permission level. The user is authorized to have the Design permission level, which by default comes with the "Add and Customize Pages" permission. The issue is that when I give the user the Design permission level, have her log off and back in, they are still unable to add a web part. – SamB. Jun 22 '17 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.